Single sign on/ldap

For complex topics that regular users would not be interested in. For power users and database administrators.

Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 8:28 am

I'm trying to get the ldap sign on to work, and I'm having a hell of a time with it. My ADDC works great, OD reads my domain users, I have all my OD accounts associated with my domain use accounts... It should be automatically logging in with the user logged into windows, but it's not. It keeps going to the login screen. What am I missing here?
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby cmcgehee » Wed Jan 03, 2018 8:42 am

I'm going to start with the simple questions: Do you have the Domain Login Enabled checkbox checked?
Chris McGehee
Open Dental Software
http://www.opendental.com
User avatar
cmcgehee
 
Posts: 496
Joined: Tue Aug 25, 2015 5:06 pm
Location: Salem, Oregon

Re: Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 9:39 am

Yes.
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby cmcgehee » Wed Jan 03, 2018 12:40 pm

I created a quick little tool that prints out the steps that are occuring when trying to log in using domain users. The tool is at http://opendentalsoft.com/forum/viewtopic.php?f=5&t=6709. If you run tool and post the output text here, I should be able to tell you what's going wrong.
Chris McGehee
Open Dental Software
http://www.opendental.com
User avatar
cmcgehee
 
Posts: 496
Joined: Tue Aug 25, 2015 5:06 pm
Location: Salem, Oregon

Re: Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 2:13 pm

Image
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby cmcgehee » Wed Jan 03, 2018 2:56 pm

The tool that I originally posted only works for OD version 17.4 and up. I compiled another one that you can use for 17.3 and posted it in the same forum thread.
Chris McGehee
Open Dental Software
http://www.opendental.com
User avatar
cmcgehee
 
Posts: 496
Joined: Tue Aug 25, 2015 5:06 pm
Location: Salem, Oregon

Re: Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 3:16 pm

Awesome! Thanks. I'm at home at the moment, but I'll probably go in to the office in a few hours to give it a try; I should have the results posted by tomorrow morning.
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 11:12 pm

Something is very clearly wrong here.....

Image
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby Restemayer » Wed Jan 03, 2018 11:24 pm

Fixed it! Your comments on the version reminded me to check what version we'd updated to most recently. 17.2, apparently. Bumping up to 17.3 resolved the problem.
Restemayer
 
Posts: 13
Joined: Tue Dec 24, 2013 11:55 pm

Re: Single sign on/ldap

Postby cmcgehee » Thu Jan 04, 2018 8:44 am

Well I'm glad it's working for you! I'm puzzled by your screenshot, but if it's fixed, I'm not going to spend time trying to figure it out.
Chris McGehee
Open Dental Software
http://www.opendental.com
User avatar
cmcgehee
 
Posts: 496
Joined: Tue Aug 25, 2015 5:06 pm
Location: Salem, Oregon


Return to Advanced Topics

Who is online

Users browsing this forum: No registered users and 4 guests