Emails not working.

For users or potential users.

Emails not working.

Postby ForrestGumpDDS » Tue Jan 29, 2019 5:21 pm

18.3.44
When trying to send an email - "Failed to send email.

Error message from the email client was:
Failure sending mail."

Upgraded to the latest stable 18.3.47
No luck.
Trying to call - no one calls back. Sorry for giving an impression of being impatient, but we have to send a bunch of emails tonight.
ForrestGumpDDS
 
Posts: 147
Joined: Fri Oct 14, 2011 3:31 pm

Re: Emails not working.

Postby jsalmon » Tue Jan 29, 2019 5:35 pm

Email clients usually give more descriptive errors. I'll see about making a ticket for getting as much raw data as possible and putting it in a different output format but that won't help you tonight. Because it's such a generic error I can only suggest generic things like make sure your firewall isn't blocking outgoing traffic on whatever port you have set up. Some email services have limits on how many emails you can send in a day / week / month so hopefully you didn't hit that limit. Last thing would be to Google other ports that your email service provider supports and try some of those instead (maybe try a non-SSL port or visa versa depending on the current settings that are now failing all of a sudden).
The best thing about a boolean is even if you are wrong, you are only off by a bit.

Jason Salmon
Open Dental Software
http://www.opendental.com
User avatar
jsalmon
 
Posts: 1464
Joined: Tue Nov 30, 2010 1:33 pm

Re: Emails not working.

Postby ForrestGumpDDS » Tue Jan 29, 2019 6:01 pm

Thanks Jason,
More descriptive error would help, but that what all I was getting, sorry...

My firewall has not changed, however I accidentally just figured out it was my Suricata behaving that way, probably after recent update.
Will be digging deeper to find out which rules are blocking gmail traffic.
ForrestGumpDDS
 
Posts: 147
Joined: Fri Oct 14, 2011 3:31 pm

Re: Emails not working.

Postby ForrestGumpDDS » Tue Jan 29, 2019 6:13 pm

Well...
Here's an idea of "more descriptive" output.
Code: Select all
108.177.XYZ.KJH
SURICATA Applayer Detect protocol only one direction - 01/29/2019-20:10:24


This is what the suricata seems to be blocking. Not sure if OD has to do anything with it.

Update. After reading this, I disabled this rule in Suricata, and now the emails go out ok. Is that an unexpected behavior from OD?
ForrestGumpDDS
 
Posts: 147
Joined: Fri Oct 14, 2011 3:31 pm

Re: Emails not working.

Postby jsalmon » Wed Jan 30, 2019 9:59 am

From the link you posted:
Protocol detection only succeeded in one direction. For FTP and SMTP this is expected.
So if you have been using these protocols from your network then you will see these alerts.

Email within Open Dental is typically sent via SMTP so I guess this is expected behavior with Suricata.
The best thing about a boolean is even if you are wrong, you are only off by a bit.

Jason Salmon
Open Dental Software
http://www.opendental.com
User avatar
jsalmon
 
Posts: 1464
Joined: Tue Nov 30, 2010 1:33 pm


Return to Main Forum

Who is online

Users browsing this forum: Google [Bot] and 10 guests